my.westernu.edu Outage

Incident Report for WesternU

Resolved

Access to My.WesternU.edu is confirmed working.
Posted Aug 19, 2025 - 11:51 PDT

Monitoring

my.WesternU.edu appears to be functioning normally now. The vendor's status page still shows degraded performance, however we are not experiencing issues. We will continue to monitor and report.
Posted Aug 18, 2025 - 11:41 PDT

Identified

Per the vendor:

[my.westernu.edu] is currently experiencing degraded service. [Our] engineers identified the issue, are taking remediation actions and will provide further updates
Posted Aug 18, 2025 - 09:09 PDT

Investigating

We are currently investigating this issue.
Posted Aug 18, 2025 - 09:00 PDT
This incident affected: Campus Services (My.WesternU.edu (previously YOU Portal)).