ExamSoft Incident - Legacy Portal Loading Issue

Incident Report for WesternU

Resolved

Examsoft has provided a final update.

The incident has been resolved and services have returned to normal.
Posted Dec 04, 2025 - 14:12 PST

Monitoring

ExamSoft has provided an update.

Performance is returning to normal, Legacy portal users should be able to now log in and navigate the portal. ExamSoft will continue to monitor.
Posted Dec 04, 2025 - 10:56 PST

Update

ExamSoft has provided an update:

ExamSoft is continuing to investigate the reports of Legacy portal issues. Currently, Users are reporting the ability to log in but slowness loading pages.
Posted Dec 04, 2025 - 10:16 PST

Investigating

ExamSoft provided of reports that some users are having issues loading or logging into the Legacy Portal.

ExamSoft is actively investigating and working to restore normal service as quickly as possible.
Posted Dec 04, 2025 - 10:16 PST
This incident affected: Third-Party Services (ExamSoft).