Pomona Power Outage

Incident Report for WesternU

Identified

The WesternU campus is experiencing a major power failure. Some buildings and facilities are affected (AAC, PCC, VMC, NSC VPC). There is NO immediate need for an evacuation if there is sufficient light in your affected building, however you may move to a building with power. PCC is not included with this protocol, please refer to PCC Power Failure Protocol. LATEST SCE Restoration Estimate: 8:30pm. Follow instructions from WesternU officials or local authorities. You will be notified when the power has been restored.
Posted Nov 19, 2025 - 17:34 PST

Investigating

Power is out in the following buildings: PCC, VMC, VPC, AAC, NSC
Posted Nov 19, 2025 - 16:32 PST
This incident affects: Campus Services (Electricity).