Epic- Reported Slowness

Incident Report for WesternU

Resolved

OCHIN has resolved the performance issues with EPIC.
Posted Apr 23, 2026 - 08:06 PDT

Monitoring

The slowness seems to have been resolved. OCHIN is currently monitoring.
Posted Apr 22, 2026 - 11:29 PDT

Investigating

OCHIN is aware of the Epic slowness and is currently investigating this issue. They hope to have a resolution soon.
Posted Apr 22, 2026 - 09:57 PDT
This incident affected: Clinical Systems (EPIC).