go.westernu.edu / Microsoft Outage

Incident Report for WesternU

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 21:09 PDT

Monitoring

Services appear to be working again via multiple confirmed reports, but nothing official from Microsoft yet. We will continue to monitor.
Posted Jun 11, 2026 - 15:00 PDT

Investigating

Microsoft is experiencing issues that is preventing access to go.westernu.edu. Microsoft has reported they are reverting to a previous build in an attempt to remediate impact as soon as possible.
Posted Jun 11, 2026 - 14:46 PDT
This incident affected: Microsoft 365 Services (Misc.).