Epic Launching Issue

Incident Report for WesternU

Resolved

Epic access is fully restored.
Posted Aug 21, 2025 - 16:47 PDT

Update

As of 9:28 AM PST, Ochin has reported that the issue impacting EPIC Production access should be resolved.

To ensure proper functionality, users are advised to: Completely exit out of EPIC Production, relaunch their browser, and restart their PC if necessary.

If issues persist, please confirm that the reported error occurred after the 9:28 AM fix and the above troubleshooting steps have been fully completed before contacting TechSupport.
Posted Aug 21, 2025 - 10:09 PDT

Monitoring

Ochin (Epic) has currently reported intermittent issues with launching Epic via Citrix. The issue was resolved earlier this morning but has presented itself again for a number of individuals. There is no current ETA for a resolution, but we will continue to update as more information becomes available.


Who/what is affected?
Users who launch EPIC via Citrix
Posted Aug 21, 2025 - 08:56 PDT
This incident affected: Clinical Systems (EPIC).